IBM Tivoli Composite Application Manager for Application Diagnostics, Version 7.1.0.1

Upgrade from ITCAM for WebSphere 6.1 on IBM i

You can upgrade from ITCAM for WebSphere 6.1 to ITCAM for Application Diagnostics 7.1 on an IBM i system (i5/OS), preserving any customized configuration. This requires an operating system upgrade to IBM i 5.4 or 6.1, as previous versions are not supported by ITCAM for Application Diagnostics 7.1.

ITCAM for WebSphere 6.1 data collector on i5/OS communicates with the Managing Server and, optionally, with the Tivoli Enterprise Monitoring Agent, both of which are installed on Windows, Linux, or UNIX systems.

You must complete the upgrade in the following order:

  1. Upgrade the operating system to IBM i 5.4 or 6.1.

  2. Upgrade the Managing Server and, if applicable, the Tivoli Enterprise Monitoring Agent.

    For any data collectors that were not updated to 6.1 fix pack 4, Tivoli Monitoring stops at this point.

  3. Install the new data collector. This installation makes the new data collector available; however, all application server instances are still monitored by the older data collector at this point.

  4. Use the new data collector configuration tool, upgrade the monitoring of each application server instance to the new data collector. For data collectors that were not updated to 6.1 fix pack 4, this step is required to reenable Tivoli Monitoring. For 6.1 fix pack 4 or later data collectors, monitoring is not interrupted, so you can perform the upgrade at a convenient time. The upgrade involves restarting the application server instance.

For more information on installing and configuring ITCAM Agent for WebSphere Applications data collector IBM i systems, see ITCAM Agent for WebSphere Applications data collector Installation Guide for IBM i. Follow the procedure in the Silent installation chapter; when preparing a response file, use the instructions for upgrade installation of the data collector.


Parent topic:

Plan an upgrade installation