zic

 


 
 
 
 Maintenance Commands                                      zic(1M)
 
 
 


NAME

zic - time zone compiler

SYNOPSIS

zic [ -s ] [ -v ] [ -l localtime ] [ -p posixrules ] [ -d directory ] [ -y yearistype ] [ filename ... ]

DESCRIPTION

zic reads text from the file(s) named on the command line and creates the time conversion information files specified in this input. If a filename is '-', the standard input is read. Input lines are made up of fields. Fields are separated by any number of white space characters. Leading and trailing white space on input lines is ignored. A pound sign (#) indicates a comment and extends to the end of the line. White space characters and pound signs may be enclosed within double quotes (" ") if they are to be used as part of a field. Any line that is blank (after comment stripping) is ignored. Non-blank lines are expected to be of one of three types: rule lines, zone lines, or link lines. Rule A rule line has the form: For example: Rule NAME FROM TO TYPE IN ON AT SAVE LETTER/S The fields that make up a rule line are: Rule USA 1969 1973 - Apr lastSun 2:00 1:00 D NAME Gives the (arbitrary) name of the set of rules this rule is part of. FROM Gives the first year in which the rule applies. The word minimum (or an abbreviation) means the minimum year with a representable time value. The word maximum (or an abbreviation) means the maximum year with a representable time value. TO Gives the final year in which the rule applies. In addition to minimum and maximum (as above), the word only (or an abbreviation) may be used to repeat the value of the FROM field. SunOS 5.8 Last change: 1 Dec 1998 1 Maintenance Commands zic(1M) TYPE Gives the type of year in which the rule applies. If TYPE is: '-' The rule applies in all years between FROM and TO inclusive. uspres The rule applies in U.S. Presidential election years. nonpres The rule applies in years other than U.S. Presidential election years. even The rule applies to even-numbered years. odd The rule applies to odd-numbered years. If TYPE is something else, then zic will attempt to execute the command yearistype year type to check the type of a year: an exit status of 0 means that the year is of the given type; an exit status of 1 means that the year is not of the given type. The yearistype command is not currently provided in the Solaris environment.) IN Names the month in which the rule takes effect. Month names may be abbreviated. ON Gives the day on which the rule takes effect. Recog- nized forms include: 5 the fifth day of the month lastSun the last Sunday in the month lastMon the last Monday in the month Sun>=8 first Sunday on or after the eighth Sun<=25 SunOS 5.8 Last change: 1 Dec 1998 2 Maintenance Commands zic(1M) last Sunday on or before the 25th Names of days of the week may be abbreviated or spelled out in full. Note: There can not be spaces within the ON field. AT Gives the time of day at which the rule takes effect. Recognized forms include: 2 time in hours 2:00 time in hours and minutes 15:00 24-hour format time (for times after noon) 1:28:14 time in hours, minutes, and seconds Any of these forms may be followed by the letter w if the given time is local "wall clock" time; s if the given time is local "standard" time; or u (or g or z) if the given time is universal time. In the absence of an indicator, wall clock time is assumed. SAVE Gives the amount of time to be added to local standard time when the rule is in effect. This field has the same format as the AT field (without the w and s suf- fixes). LETTER/S Gives the "variable part" (for example, the "S" or "D" in "EST" or "EDT" of time zone abbreviations to be used when this rule is in effect. If this field is '-', the variable part is null. Zone A zone line has the form: Zone NAME GMTOFF RULES/SAVE FORMAT [UNTIL] For example: Zone Australia/SouthWest 9:30 - CST 1992 Mar 15 12:00 8:30 Aus CST The fields that make up a zone line are: SunOS 5.8 Last change: 1 Dec 1998 3 Maintenance Commands zic(1M) NAME The name of the time zone. This is the name used in creating the time conversion information file for the zone. GMTOFF The amount of time to add to GMT to get standard time in this zone. This field has the same format as the AT and SAVE fields of rule lines; begin the field with a minus sign if time must be subtracted from GMT. RULES/SAVE The name of the rule(s) that apply in the time zone or, alternately, an amount of time to add to local standard time. If this field is `-' then standard time always applies in the time zone. FORMAT The format for time zone abbreviations in this time zone. The pair of characters %s is used to show where the "variable part" of the time zone abbreviation goes. UNTIL The time at which the GMT offset or the rule(s) change for a location. It is specified as a year, a month, a day, and a time of day. The time of day has the same format as the AT field of rule lines. If this is specified, the time zone information is generated from the given GMT offset and rule change until the time specified. The next line must be a "continuation" line; this has the same form as a zone line except that the string "Zone" and the name are omitted, as the continuation line will place information starting at the time specified as the UNTIL field in the previous line in the file used by the previous line. Continuation lines may contain an UNTIL field, just as zone lines do, indicating that the next line is a further continua- tion. Link A link line has the form: Link LINK-FROM LINK-TO For example: Link US/Eastern EST5EDT SunOS 5.8 Last change: 1 Dec 1998 4 Maintenance Commands zic(1M) The LINK-FROM field should appear as the NAME field in some zone line; the LINK-TO field is used as an alternate name for that zone. Except for continuation lines, lines may appear in any order in the input.

OPTIONS

-d directory Create time conversion information files in the direc- tory directory rather than in the standard directory /usr/share/lib/zoneinfo. -l localtime Use the given time zone as local time localtime. zic will act as if the file contained a link line of the form: Link localtime localtime -p posixrules Use the rules of the given time zone posixrules when handling POSIX-format time zone environment variables. zic will act as if the input contained a link line of the form Link posixrules posixrules This option is not used by ctime(3C) and mktime(3C) in the Solaris environment. -s Limit time values stored in output files to values that are the same whether they are taken to be signed or unsigned. You can use this option to generate SVVS-compatible files. -v Complain if a year that appears in a data file is out- side the range of years representable by system time values (0:00:00 a.m. GMT, January 1, 1970, to 3:14:07 a.m. GMT, January 19, 2038). -y yearistype Use the given command yearistype rather than yearis- type when checking year types (see Rules under DESCRIPTION). SunOS 5.8 Last change: 1 Dec 1998 5 Maintenance Commands zic(1M)

OPERANDS

filename A file containing input lines that specify the time conversion information files to be created. If a filename is '-', the standard input is read.

FILES

/usr/share/lib/zoneinfo standard directory used for created files

ATTRIBUTES

See attributes(5) for descriptions of the following attri- butes: ____________________________________________________________ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | |_____________________________|_____________________________| | Availability | SUNWcsu | |_____________________________|_____________________________|

SEE ALSO

time(1), zdump(1M), ctime(3C), mktime(3C), attributes(5)

NOTES

For areas with more than two types of local time, you may need to use local standard time in the AT field of the ear- liest transition time's rule to ensure that the earliest transition time recorded in the compiled file is correct. SunOS 5.8 Last change: 1 Dec 1998 6