Software requirements

Before you can install the product, verify that your system meets the software requirements.


Table 1. Software requirements to install Rational Functional Tester

Item Requirements
Platform

One of the following operating systems must be installed:

Supported operating systems in 32-bit mode

  • Microsoft Windows XP Professional with Service Pack 2 or 3

  • Microsoft Windows 2000 Professional with Service Pack 4

  • Microsoft Windows 2000 Server with Service Pack 4

  • Microsoft Windows 2000 Advanced Server with Service Pack 4

  • Microsoft Windows 2003 Server Standard Edition with Service Pack 1 or 2

  • Microsoft Windows 2003 Server Enterprise Edition with Service Pack 1 or 2

  • Microsoft Windows Vista Business, Windows Vista Enterprise, and Windows Vista Ultimate, Service Pack 1, Service Pack 2

  • Microsoft Windows 2008 Server Standard Edition with Service Pack 1

    The Hyper-V host is not supported, but the guest operating system that is supported by Rational Functional Tester and hosted on Hyper-V is supported.

  • Microsoft Windows 7 Ultimate, Enterprise and Professional

  • Red Hat Enterprise Linux AS 4.0, Update 5, Update 8 (All functions except recording)

  • Red Hat Enterprise Linux ES 4.0, Update 1 (All functions except recording)

  • Red Hat Enterprise Linux 5.0 (Server) Update 3, Update 4 (All functions except recording) (All functions except recording)

  • Red Hat Enterprise Linux Desktop 4.0, Update 1, Update 7, Update 8 (All functions except recording)

  • Red Hat Enterprise Linux Desktop 5.0 Update 2, Update 3, Update 4 (All functions except recording)

  • SUSE Linux Enterprise Server (SLES) 9.0, SP4 (All functions except recording)

  • SUSE Linux Enterprise Server (SLES) 10.0, SP1, SP2, SP3 (All functions except recording)

  • SUSE Linux Enterprise Server (SLES) 11.0 (All functions except recording)

  • SUSE Linux Enterprise Desktop 10.0, SP1, SP2 (All functions except recording)

  • SUSE Linux Enterprise Desktop 11.0 (All functions except recording)

Rational Functional Tester provides support for testing applications on a computer that has Federal Desktop Core Configuration (FDCC) setup on Microsoft Windows XP, Microsoft Windows Vista and Microsoft Windows 7 operating system. For more information, see the technote. http://www.ibm.com/support/docview.wss?uid=swg21416816

Supported operating systems in 64-bit mode

  • Microsoft Windows XP Professional 64

  • Microsoft Windows Vista 64 Business, Ultimate and Enterprise

  • Microsoft Windows 2003 Server 64

  • Microsoft Windows 7 Ultimate, Enterprise and Professional

  • Microsoft Windows Server 2008

Rational Functional Tester provides limited support for testing applications on 64-bit mode. You can test Windows and .NET 64-bit applications in the 64-bit Windows operating system. You can also test all the supported 32-bit applications that run in 32-bit mode in the 64-bit Windows operating system. For more information, see the product release notes and the tech. notes in the Support site.

The listed operating systems support all of the languages that are supported by Rational Functional Tester .

Others

  • Microsoft .NET Framework 2.0, 3.0, 3.5 for recording functional test scripts on any Windows applications

  • Microsoft Visual Studio.Net 2003, Standard Edition or Professional Edition, with VB.NET Project support for .NET 2003 scripting.

  • Microsoft Visual Studio.Net 2005, Standard Edition or Professional Edition, with VB.NET Project support for .NET 2005 scripting .

  • For Linux:

    • If you are using Red Hat Enterprise Linux 5, Update 4 and later, to install using , disable SELinux. You can disable SELinux either temporarily or permanently. See Troubleshooting Rational Functional Tester

    • The GNU Image Manipulation Program Toolkit (GTK+), Version 2.2.1 to 2.17

    • Libraries:

      • libXp.so.6 must be available in the computer. If it is not available on the computer, install the appropriate libxp-1.rpm package for i386 or i586 that contains this library.

      • libstdc++.so.5must be available in the computer. If it is not available on the computer, install the appropriate compat-libstdc++-5.0.7-121.1.i586.rpm package.
Extending an existing Eclipse IDE

To install Rational Functional Tester into an existing eclipse, you require:

  • Eclipse 3.4.2 or higher

  • For Windows: IBM 32-bit SDK for Windows, Java 2 Technology Edition, Version 6 or Sun Java 2 Standard Edition 6

  • For Linux: IBM 32-bit SDK for Linux on Intel® architecture, Java 2 Technology Edition, Version 6 or Sun Java 2 Standard Edition 6

You can install Rational Functional Tester on an existing Rational Team Concert™ client and manage functional test assets using the Jazz™ source control management. Jazz Eclipse Client for Rational Team Concert/Rational Quality Manager is also provided as an optional feature installation. You must have the compatible Rational Team Concert or Rational Quality Manager server setup for using the Jazz source control management. Refer to the Rational Team Concert documentation for the supported list of platforms.

Important: To enable users who do not have Administrator privileges to work with Rational Functional Tester on a Windows Vista system, do not install Eclipse inside the Program Files directory (C:\Program Files\).

Virtualization software

The following virtualization software is supported:

  • Citrix Presentation Manager Version 4 or 4.5, running on Windows Server 2003 Standard Edition or Windows Server 2003 Professional Edition

  • Citrix XenApp 5.0 for Windows Server 2008

For information about the list of platforms that are supported by Rational Functional Tester 8.x releases, see the list of supported platforms technical document.