Administration guide > Upgrade and migrating WebSphere eXtreme Scale v7.1



Migrating to WebSphere eXtreme Scale v7.1

With the WebSphere eXtreme Scale installer, you cannot upgrade or modify a previous installation. You must uninstall the previous version before you install the new version. You do not need to migrate the configuration files because they are backward compatible. However, if you changed any of the script files that are shipped with the product, reapply these changes to the updated script files.


Before you begin

Verify that the systems meet the minimum requirements for the product versions you plan to migrate and install. See Hardware and software requirements for more information.

Merge any modified product script files with new product script files in the /bin directory to maintain the changes.

Tip: If you did not modify the script files that are installed with the product, you are not required to complete the following migration steps. Instead, you can upgrade to v7.1 by uninstalling the previous version and installing the new version in the same directory.


Procedure

  1. Stop all processes that are using eXtreme Scale.

  2. Save any modified scripts from the current installation directory to a temporary directory.

  3. Uninstall the product.

  4. Install eXtreme Scale v7.1. See Install WebSphere eXtreme Scale for more information.

  5. Merge the changes from the files in the temporary directory to the new product script files in the /bin directory.

  6. Start all of the eXtreme Scale processes to begin using the product. See Operate the deployment environment for more information.


Parent topic:

Upgrade and migrating WebSphere eXtreme Scale v7.1


Related concepts

Hardware and software requirements