X-Windows
AIX
- Verify X11 filesets are installed:
# lslpp -l grep X11
lslpp: 0504-132 Fileset grep not installed.
lslpp: 0504-132 Fileset X11 not installed.
- On remote host, edit /etc/ssh/sshd_config and uncomment the line "X11 Forwarding yes"
- If changes are made, restart the ssh daemon:
stopsrc -s sshd
startsrc -s sshdRestart sshd.
stopsrc -s sshd
startsrc -s sshd
- Start Mocha X on your PC
Or you can try using using Hummingbird eXceed on your PC. If using eXceed, edit...
- In putty, enable X11 Forwarding and set X display location to localhost
- For Linux
- Log on to your linux box and run..
xauth list
- Copy output. For example...
hostname/unix:10 MIT-MAGIC-COOKIE-1 06eccfef8f06993f48fb059adeda8376
- sudo to your desired user
- Run...
xauth add
...and paste contents of xauth list command. For example
xauth add hostname/unix:10 MIT-MAGIC-COOKIE-1 06eccfef8f06993f48fb059adeda8376
- Set DISPLAY...
DISPLAY=localhost:10.0
export DISPLAY
- Run xclock to test
Note that two people cannot both run X Windows if they are each logged on with the same user id.
Linux
- Start the Mocha X on your PC
- In putty, enable X11 Forwarding and set X display location to localhost
- Log on to your linux box
- Run...
xauth list
...and copy output. For example...
hostname/unix:10 MIT-MAGIC-COOKIE-1 06eccfef8f06993f48fb059adeda8376
- sudo to your desired user
- Run...
xauth add
...and paste contents of xauth list command. For example
xauth add hostname/unix:10 MIT-MAGIC-COOKIE-1 06eccfef8f06993f48fb059adeda8376
- Run xclock to test
X11 from a jumpbox
Log on to jump box and Display Manager with Exceed as your X11 server:
Once on jumpbox, forward your display via SSH to the remote machine as...
ssh -X <hostname>Using Exceed X11 server and other ssh client (putty)
Make sure X11 forwarding is enabled on ssh client (in putty under SSH>Tunnels)