(dist)(iseries)

Configure IBM HTTP Server powered by Apache 2.x

This topic describes how to change configuration settings for IBM HTTP Server powered by Apache 2.x.

(iseries) If we are running IBM HTTP Server (powered by Apache) on IBM i, we can use the manual configuration steps outlined below with the IBM Web Administration for IBM i.

(dist) After you install the web server plug-ins, we can use the Web Server Plug-ins Configuration Tool to configure a web server plug-in.

This topic describes how to configure the IBM HTTP Server. Other procedures in Edit web server configuration files describe configuring other supported web servers.

Perform the step that configures IBM HTTP Server version 2.2 for the operating system. IBM HTTP Server powered by Apache 2.2 is supported on IBM i Versions 6.1 and 7.1.

Examples and messages are shown on more than one line for clarity. Place each directive in a web server configuration file on one line.

Local file path means a file path to the plugin-cfg.xml file on an spplication server that is on the same machine as the web server. Remote file path means the file path to the plugin-cfg.xml file when the spplication server is on a remote machine.

(dist) The Web Server Plug-ins Configuration Tool installs a dummy plugin-cfg.xml file during installation, but this file requires periodic propagation from the real file on the spplication server machine.

The web server definition name in the following examples is webserver1.

(dist) The node name node in the following spplication server local file paths is web_server_name_node for a standalone spplication server or managed_node for a managed node.


Results

This procedure results in editing and re-configuring IBM HTTP Server powered by Apache 2.x.


What to do next

If the IBM HTTP Server 1.3.2x directive, LoadModule ibm_app_server_http_module, is present in an IBM HTTP Server 2.x httpd.conf file, the IBM HTTP Server cannot start. We must comment or delete the directive to start the Version 2.x server.

(dist) The mod_was_ap20_http plug-in module requires the GSKIT SSL encryption library if the plug-in is configured to support encrypted connections to back-end application servers.

(dist) Install the web server plug-ins installs the GSKIT SSL encryption library at the required level if it is not installed. If we manually copy the plug-in to a new machine, you might not have the required GSKIT libraries for encrypting back-end connections.

After configuring a web server, we can install applications on it. See the Applications section of the information center for more information.

To unconfigure a web server, reverse the manual steps and remove what was manually added in this procedure.


Related tasks

  • Configure Apache HTTP Server V2.2
  • Configure IBM HTTP Server v8.5