Preparing Red Hat Enterprise Linux 3 for installation

You must complete additional steps to prepare a Red Hat Enterprise Linux V3 system for a WAS installation.

 

Before you begin

Complete steps 1-10 in Preparing Linux systems for installation . Those steps are common to any Linux system.

 

About this task

In addition to the common steps required for installing any Linux system, a few system specific steps are required for Red Hat Enterprise Linux V3.

Ensure that your installation of Red Hat Enterprise Linux 3 has been upgraded to service level 2 (update 2) or later. If you have not upgraded the service level, certain national language issues in the released version of GLIBC included in Red Hat Enterprise Linux 3 might cause Java virtual machine (JVM) failures that manifest as segmentation faults. These failures can occur during installation when the locale is set to anything other than an English locale.

Verify that the prerequisite packages are installed. A Linux package registration limitation prevents the prerequisites checker program from examining prerequisite packages on Linux systems. See Installing and verifying Linux packages for more information.

 

Procedure

  1. If you have a Red Hat Enterprise Linux 3 for xSeries platform, install the following packages.

    compat-libstdc++-7.3-2.96.122

    Required for C++ runtime compatibility. Used by such components as GSKit, the Java 2 Software Development Kit (SDK), and Web server plug-ins for WebSphere Application Server.

    compat-db-4.0.14-5

    Required by some IBM HTTP Server modules. The modules use the libraries contained within this RPM package.

    rpm-build-4.2.1-4.2

    InstallShield for Multiplatforms (ISMP) requires the package to properly register products with the Red Hat Package Manager (RPM) database.

  • If you intend to compile Java Native Interface (JNI) libraries on the system, install RPM packages that are recommended for developing and building JNI libraries for use by your Java 2 Enterprise Edition (J2EE) applications.

    The needed packages are:

    If you do not intend to compile JNI libraries on the system, you do not have to install these packages.

  • If you have an iSeries platform or pSeries platform, install the rpm-build-4.2.1-4.2 package.

    InstallShield for Multiplatforms (ISMP) requires the package to properly register products with the Red Hat Package Manager (RPM) database.

  • If you have Red Hat Enterprise Linux 3 for S/390 (z/VM or VM/ESA) platform, install the following packages.

    You can install a later release of any of these packages.

     

    Results

    If you do not install all of the required packages, the product will not perform as intended.

     

    What to do next

    After you complete the steps in this topic, proceed to the final step in Preparing Linux systems for installation .


    Related tasks
    Preparing to install Network Deployment on a Linux system Preparing Linux systems for installation

     



     

     

    WebSphere is a trademark of the IBM Corporation in the United States, other countries, or both.
    IBM is a trademark of the IBM Corporation in the United States, other countries, or both.